Huawei Agile Distributed Wi-Fi Solution: Що це? Частина перша

Напевно, багато користувачів habrahabr бачили статтю в блозі компанії Huawei – У вас тут є Wi-Fi? В якій йдеться про не легкої долі корпоративного WiFi-доступу, в умовах повсюдного зростання числа бездротових пристроїв та мережевої інфраструктури в цілому.
Ось, наприклад, цитати з неї:
За оцінками аналітиків, вже в 2019 році обсяги користувача трафіку, що передається через мережі Wi-Fi, перевищать обсяги, що припадають на дротові підключення.

Очевидно, якщо доступ до корпоративної інфраструктури допомогою Wi-Fi стає пріоритетним методом підключення, то на нього будуть накладатися і жорсткіші вимоги з безпеки, якості роботи, гнучкості і масштабування.
Все це тягне за собою необхідність модернізації інфраструктури WLAN і впровадження сучасних рішень рівня Enterprise. Ось тут виникає перший сюрприз: для керівництва практично будь-якого підприємства чи компанії Wi-Fi просто працює чудесним чином за допомогою «чарівної коробочки», яка коштує 3 тисячі рублів. І «це незбагненно», як точка доступу може коштувати 30 і більше тисяч рублів! А ще «вам, айтішникам» якийсь бездротової контролер подавай!
Розв'язкою цього складного питання стало рішення — Huawei Agile Distributed Wi-Fi, про який власне і йдеться в статті вендора. Нам же, пощастило, наскільки я розумію, одними з перших в Росії, «помацати» це рішення в живу.

Для всебічного дослідження ми отримали, так скажемо, демо комплект, що складається з:

  • Однієї центральної точки доступу (Central AP) – AP9430DN-12
  • радіо Двох модулів (RRU – Radio Remote Unit) – R230D.

Концепція

Типове застосування Agile Distributed WLAN – це сценарій з високою концентрацією приміщень, таких як: готелі, школи, гуртожитки, лікарні, тобто об'єкти, де стіни або інші елементи конструкції будівель можуть призводити до серйозного загасання Wi-Fi сигналу. Інакше кажучи, де використання традиційної архітектури WLAN-мереж не ефективно або надмірно затратно, у зв'язку з необхідністю встановлення більшої кількості точок доступу, для більш краще радіо покриття.

Як ми вже знаємо, Agile Distributed WLAN складається з центральної точки доступу, віддалених радіо модулів (RRU). RRU приймають і відправляють «бездротові» пакети і прозоро передають їх до центральної точки доступу для обробки.

Центральна точка доступу з'єднана з RRU через UTP кабель. Порівняно з антенним кабелем, що використовується для класичних точок доступу, при винесенні зовнішніх антен, «мідь» забезпечує більшу відстань розгортання WLAN, дозволяючи далі розносити RRU від центральної точки доступу, дотягуючись до «мертвих» зон.

Центральна точка доступу забезпечує RRU харчуванням за PoE, при цьому сама може бути запитана через UPoE (відноситься до моделі AP9430DN-12). Також RRU можуть бути підключені через PoE комутатор, за умови IP-досяжності (Layer2) з центральної AP.

І ще трохи теорії по темі.
Після того, як радіо модулі (RRU) підключені і отримали IP-адреси від центральної точки доступу, вони починають встановлювати CAPWAP (Control And Provisioning of Wireless Access Points) тунелі з центральною точкою доступу.

CAPWAP тунелі використовують протокол DTLS (Datagram Transport Layer Security) шифрування і, так зване, «heartbeat detection виявлення (дає можливість перевіряти і підтримувати активними з'єднання без постійного їх відновлення), для забезпечення безпеки.

Central AP посилає керуючі пакети і пакети даних до радіо модулів (RRU) у централізованому порядку, через CAPWAP тунелі. Для підвищення надійності каналу зв'язку і для запобігання втрат, коли обсяг обслуговуваного трафіку зростає, налаштовується високий пріоритет для пакетів управління CAPWAP.

Крім цього, радіо модулі (RRU) в процесі свого запуску вміють визначати, чи є їх версія системного програмного забезпечення такої ж, як у центральній точці доступу, у відповідності з параметрами у прийнятому пакеті Authentication Response. Якщо такої відповідності немає, то радіо модулі переходять в offline режим і не беруть участь в роботі.

Первісна настройка

Отже, перейдемо безпосередньо до початкового налаштування системи Agile Distributed WLAN.

Що ми хочемо зробити:

  • Зібрати стенд з AP9430DN-12 і 2хR230D і перевірити його працездатність
  • Призначити IP-адреси з нашої LAN мережі
  • Налаштувати WLAN сервіси, на прикладі Small-Scale Network WLAN
  • Надати STA доступ до мережі Інтернет
Так як, по не зрозумілим для нас причин, в комплекті поставки не було блоку живлення для центральної точки доступу, ми вирішили живити її від старенького PoE комутатора HP ProCurve, при цьому, як уже говорилося, радіо модулі були запитані з PoE від самої AP9430DN-12.

Таким чином, схема організації зв'язку виглядає наступним чином:

  • Центральна точка доступу AP9430DN-12 uplink-інтерфейсом GE 0/0/12 дивиться в LAN-мережу (Vlanif1, 172.31.31.120)
  • Радіо модулі R230D підключені на downlink-інтерфейси GE 0/0/8..9 (Vlanif100, виділення адрес динамічно через DHCP: 10.23.100.0/24)
  • Клієнти, підключені до Wi-Fi мережі (STA) отримують адреси через DHCP: 10.23.101.0/24 (Vlanif101)
  • SSID: agile_wlan


Логін/пароль за замовчуванням для консолі: admin / admin@huawei


Актуальна версія системного програмного забезпечення, на момент написання статті — V200R007C10SPC300:

<Agile_Wlan>display version
Huawei Versatile Routing Platform Software
VRP ® software, Version 5.160 (AD9430DN-12 FAT V200R007C10SPC300)
Copyright © 2011-2016 HUAWEI TECH CO., LTD
Huawei AD9430DN-12 Router uptime is 1 week, 0 day, 1 hour, 8 minutes



CLI

# Пропишемо ім'я пристрою, IP-адреси управління, а також маршрут за замовчуванням:

<Huawei> system-view
[Huawei] sysname Agile_Wlan
[AGILE_WLAN] vlan 1
[AGILE_WLAN-vlan1] quit
[AGILE_WLAN] interface gigabitethernet 0/0/12
[AGILE_WLAN-GigabitEthernet0/0/0] port link-type trunk
[AGILE_WLAN-GigabitEthernet0/0/0] port trunk allow-pass vlan 1
[AGILE_WLAN-GigabitEthernet0/0/0] port trunk pvid vlan 1
[AGILE_WLAN-GigabitEthernet0/0/0] quit
[AGILE_WLAN] interface vlanif 1
[AGILE_WLAN-Vlanif1] ip address 172.31.31.120 255.255.255.0
[AGILE_WLAN-Vlanif1] ip route-static 0.0.0.0 0.0.0.0 172.31.31.120
[AGILE_WLAN-Vlanif1] quit

#Налаштовуємо доступ по SSH до пристрою, предвариетльно створивши користувача та згенерувавши ключі rsa:

[AGILE_WLAN]rsa local-key-pair create
The key name will be: Host
RSA keys defined for Host already exist.
Confirm to replace them? (y/n):y
The range of public key size is (512 ~ 2048).
NOTES: If the key modulus is less than 2048,
It will introduce potential security risks.
Input the bits in the modulus[default = 2048]:
Generating keys...
...........................................................................................................................................+++
....................+++
..............................................++++++++
................++++++++
[AGILE_WLAN]user-interface vty 0 4
[AGILE_WLAN-ui-vty0-4]authentication-mode aaa
[AGILE_WLAN-ui-vty0-4]protocol inbound ssh
[AGILE_WLAN-ui-vty0-4]quit
[AGILE_WLAN]aaa
[AGILE_WLAN-aaa]local-user user1 password irreversible-cipher Pa$$w0rd
[AGILE_WLAN-aaa]local-user user1 privilege level 15
[AGILE_WLAN-aaa]local-user user1 service-type ssh http terminal
[AGILE_WLAN]ssh user user1 authentication-type password

#Додамо інтерфейси GE 0/0/8..9 у керуючий VLAN100:

[AGILE_WLAN] vlan batch 100 101
[AGILE_WLAN] interface gigabitethernet 0/0/8
[AGILE_WLAN-GigabitEthernet0/0/1] port link-type trunk
[AGILE_WLAN-GigabitEthernet0/0/1] port trunk pvid vlan 100
[AGILE_WLAN-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
[AGILE_WLAN-GigabitEthernet0/0/1] quit

#Додамо uplink інтерфейс GE 0/0/12 в сервісний VLAN101:

[AGILE_WLAN] interface gigabitethernet 0/0/12 
[AGILE_WLAN-GigabitEthernet0/0/12] port link-type trunk 
[AGILE_WLAN-GigabitEthernet0/0/12] port trunk allow-pass vlan 101 
[AGILE_WLAN-GigabitEthernet0/0/12] quit

#Налаштуємо центральну точку доступу в якості сервера DHCP для RRU і STA:

[AGILE_WLAN] dhcp enable
[AGILE_WLAN] interface vlanif 100
[AGILE_WLAN-Vlanif100] ip address 10.23.100.1 24
[AGILE_WLAN-Vlanif100] dhcp select interface
[AGILE_WLAN-Vlanif100] quit
[AGILE_WLAN] interface vlanif 101
[AGILE_WLAN-Vlanif101] ip address 10.23.101.1 24
[AGILE_WLAN-Vlanif101] dhcp select interface
[AGILE_WLAN-Vlanif101] quit

#Створимо AP group:

[AGILE_WLAN] wlan
[AGILE_WLAN-wlan-view] ap-group name ap-group1
[AGILE_WLAN-wlan-ap-group-ap-group1] quit

#Створимо профіль для regulatory domain, код країни і застосуємо профіль для ap-group:

[AGILE_WLAN-wlan-view] regulatory-domain-profile name domain1
[AGILE_WLAN-wlan-regulate-domain-domain1] country-code ru
[AGILE_WLAN-wlan-regulate-domain-domain1] quit
[AGILE_WLAN-wlan-view] ap-group name ap-group1
[AGILE_WLAN-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
e?[Y/N]:y 
[AGILE_WLAN-wlan-ap-group-ap-group1] quit
[AGILE_WLAN-wlan-view] quit

#Призначимо керуючий VLAN для RRU:

[AGILE_WLAN] management vlan 100

#Додаємо в конфігурацію радіо модулі RRU (використовуємо метод автентифікації):

[AGILE_WLAN] wlan
[AGILE_WLAN-wlan-view] ap auth-mode no-auth
[AGILE_WLAN-wlan-view] ap-id 1 
[AGILE_WLAN-wlan-view] ap-id 2
[AGILE_WLAN-wlan-ap-1] ap-name area_1
[AGILE_WLAN-wlan-ap-1] ap-group ap-group1
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
s of the radio, Whether to continue? [Y/N]:y 
[AGILE_WLAN-wlan-ap-1] quit

#Підключаємо радіо модулі і перевіряємо їх стан:

[Agile_Wlan-wlan-view]display all ap
Info: This operation may take a few seconds. Please wait for a moment.done.
Total AP information:
nor : normal [2]
-------------------------------------------------------------------------------------------------------------
ID MAC Group Name Type IP State STA Uptime
-------------------------------------------------------------------------------------------------------------
1 9c50-ee25-2240 9c50-ee25-2240 ap-group1 10.23.100.215 R230D nor 0 4D:0H:25M:16S
2 9c50-ee25-1c00 9c50-ee25-1c00 ap-group1 10.23.100.225 R230D nor 0 4D:0H:25M:53S
-------------------------------------------------------------------------------------------------------------
Total: 2

#Налаштовуємо параметри WLAN (security, ssid, vap):

[AGILE_WLAN-wlan-view] security-profile name wlan-security
[AGILE_WLAN-wlan-sec-prof-wlan-security] security psk, wpa2 pass-phrase 12345678 aes
[AGILE_WLAN-wlan-sec-prof-wlan-security] quit

[AGILE_WLAN-wlan-view] ssid-profile name wlan-ssid
[AGILE_WLAN-wlan-ssid-prof-wlan-ssid] ssid agile_wlan
[AGILE_WLAN-wlan-ssid-prof-wlan-ssid] quit

[AGILE_WLAN-wlan-view] vap-profile name wlan-vap
[AGILE_WLAN-wlan-vap-prof-wlan-vap] service-vlan vlan id 101
[AGILE_WLAN-wlan-vap-prof-wlan-vap] security-profile wlan-security
[AGILE_WLAN-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
[AGILE_WLAN-wlan-vap-prof-wlan-vap] quit

[AGILE_WLAN-wlan-view] ap-group name ap-group1
[AGILE_WLAN-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
[AGILE_WLAN-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
[AGILE_WLAN-wlan-ap-group-ap-group1] quit

#Перевіряємо конфігурацію:

[Agile_Wlan]display vap ssid agile_wlan
Info: This operation may take a few seconds, please wait.
WІ : WLAN ID
-------------------------------------------------------------------------------------
AP ID AP name RfID WID BSSID Status Auth type STA SSID
-------------------------------------------------------------------------------------
1 9c50-ee25-2240 0 1 9C50-EE25-2240 ON Open+Portal 0 agile_wlan
1 9c50-ee25-2240 1 1 9C50-EE25-2250 ON Open+Portal 0 agile_wlan
2 9c50-ee25-1c00 0 1 9C50-EE25-1C00 ON Open+Portal 1 agile_wlan
2 9c50-ee25-1c00 1 1 9C50-EE25-1C10 ON Open+Portal 0 agile_wlan
-------------------------------------------------------------------------------------
Total: 4

[Agile_Wlan]display station ssid agile_wlan
Rf/WLAN: Radio ID/WLAN ID
Rx/Tx: link receive rate/link transmit rate(Mbps)
-------------------------------------------------------------------------------------------------
STA MAC AP ID Ap name Rf/WLAN Band Type Rx/Tx RSSI VLAN IP address
-------------------------------------------------------------------------------------------------
a8c8-3a05-e343 2 9c50-ee25-1c00 0/1 2.4 G 11n 5/2 -83 101 10.23.101.248
-------------------------------------------------------------------------------------------------
Total: 1 2.4 G: 1 5G: 0

Для конфігурування системи, також доступний Web-інтерфейс:





Кінець першої частини.
Джерело: Хабрахабр

0 коментарів

Тільки зареєстровані та авторизовані користувачі можуть залишати коментарі.