Mikrotik: маленька хитрість switch chip

Моя минула стаття про switch chip на Mikrotik викликала неоднозначну реакцію, а коментар одного з читачів наштовхнув на ідею. І так: як на RB952Ui-5ac2nD зробити більш однієї групи комутації?

Обходимо обмеження чіпа Atheros8227
(думаю з іншими можна аналогічно)

Ідея тут проста, спасибі Ivan_83 за ідею (саме його коментар — дав напрямок думки).

Сформулюємо проблему: є домашній інтернет з телебаченням, але на приставку потрібно дати кабель не після нашого NAT, а до нього. Зазвичай провайдер пропонує маленький комутатор до вашого роутера (який жах, стільки непотрібних пристроїв!), або якщо роутер вміє, ви створюєте на ньому міст з двох портів, які віддаєте зовнішньої мережі (вхідний кабель+приставка ТБ). Але, вищезазначений Mikrotik не вміє дві групи комутації, і тому доводиться робити софтовый bridge (а хочеться віддати це в «залізо»).

Тепер реалізація: об'єднаємо всі порти в групу комутації (виставимо майстер порт):

/interface ethernet set ether1 master-port=ether2-master



Аналогічно для всіх інших.

Тепер візьмемо, і створимо два VLAN, один для зовнішньої мережі (наприклад VID:1) і для внутрішньої (VID:2):


/interface vlan
add interface=ether2-master \
name=ext vlan id=1
add interface=ether2-master \
name=V_LAN vlan id=2



І на чіпі комутації «об'єднаймо» порти за допомогою VLAN. Всі порти будуть растегированны (крім CPU), і VLAN за замовчуванням буде той, який відповідає призначенню порту (для зовнішньої мережі 1, для внутрішньої 2):


/ethernet interface port switch
set ether1 default-vlan id=1 vlan-header=always-strip vlan-mode=secure
set ether2-master default-vlan id=1 vlan-header=always-strip vlan-mode=secure
set ether3 default-vlan id=2 vlan-header=always-strip vlan-mode=secure
set ether4 default-vlan id=2 vlan-header=always-strip vlan-mode=secure
set ether5 default-vlan id=2 vlan-header=always-strip vlan-mode=secure
set switch1-cpu default-vlan id=2 vlan-header=add-if-missing vlan-mode=secure



Тепер створюємо таблицю VLAN:

/interface ethernet switch vlan
add ports=ether1,ether2-master,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan id=1
add ports=ether1,ether2-master,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan id=2



Все, тепер чіп комутації зробить потрібну нам роботу.
Джерело: Хабрахабр

0 коментарів

Тільки зареєстровані та авторизовані користувачі можуть залишати коментарі.