Хостим персональний сайт на роутері

Доброго часу доби.

Пару тижнів тому я вирішив створити персональний сайт з декількома сторінками про себе, свої досягнення, цілі і контактах. Зрозуміло, одним із етапів його створення стало питання вибору хостингу. Віддавати гроші за розміщення сайту на чиємусь сервері мені не хотілося, та й залишати свій домашній комп'ютер постійно включеним теж.

Поміркувавши, я згадав цікаву статті про налаштування сервера ip-телефонії Asterisk на маршрутизатор Mikrotik. Так як у мене вдома встановлений роутер саме цього проиводителя, не роздумуючи, я вирішив підняти на ньому веб-сервер nginx.

Отже, ми маємо зарегестриваронное доменне ім'я, «білий» статичний ip-адресу і маршутизатор Mikrotik RB751G-2HnD c чудовою функцією MetaRouter. Почнемо з вибору способу openwrt для нашого маршрутизатора. Зайдемо на роутер через програму winbox і подивимося на його архітектуру. У моделі RB751G-2HnD архітектура mipbse:



Викачуємо з сайту останній образ openwrt для mipbse звідси. Копіюємо на роутер в Files:



Імпортуємо образ openwrt в метароутер, і додаємо мережевий інтерфейс для нашого віртуального образу:
/metarouter import-image file-name=openwrt-mr-mips-rootfs-31411-basic.tar.gz memory=24 enabled=yes
/metarouter interface add virtual-machine=mr2 type=dynamic dynamic-bridge=bridge_local

Потім входимо в консоль образу і першим ділом встановлюємо пароль користувача root.



Редагуємо налаштування мережі для отримання мережевих реквізитів по dhcp від самого роутера:
vi /etc/config/network

config interface lan
option ifname eth0
option proto dhcp

Додаємо службу мережі в автозавантаження і перезапускаємо:
/etc/init.d/enable network
/etc/init.d/network restart

Ми отримали мережеві реквізити, і тепер у нас є доступ до системи по ssh.



Редагуємо конфігураційний файл пакет-менеджера для оновлення репозиторію і встановлення необхідних програм:
vi /etc/opkg.conf

src/gz snapshots http://openwrt.wk.cz/trunk/mr-mips/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Далі, оновлюємо репозиторій і встановлюємо nginx і php:
opkg update
opkg install nginx php5 php5-fastcgi

Переходимо до налаштування веб-сервера.
mv /etc/nginx/nginx.conf /etc/nginx/nginx_example.conf
vi /etc/nginx/nginx.conf

user nobody nogroup;
worker_processes 1;

error_log logs/error.log;

events {
worker_connections 1024;
}

http {
include mime.types;
index index.php index.html index.htm;
default_type text/html;

sendfile on;
keepalive_timeout 65;
gzip on; 
gzip_buffers 4 16k;
gzip_http_version 1.0;
gzip_comp_level 2;
gzip_types text/plain application/x-javascript text/css application/xml;
gzip_vary on;
gzip_min_length 1k;

server {
listen 80; # слухає порт
server_name 172.16.0.12; # ім'я або ip-адресу сервера
fastcgi_connect_timeout 300;
fastcgi_send_timeout 300;
fastcgi_read_timeout 300;
fastcgi_buffer_size 32k;
fastcgi_buffers 4 32k;
fastcgi_busy_buffers_size 32k;
fastcgi_temp_file_write_size 32k;
client_body_timeout 10;
client_header_timeout 10;
send_timeout 60;
output_buffers 1 32k;
postpone_output 1460;
root /srv/www; # Папка з файлами сайту

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;

if (-f $request_filename) {
fastcgi_pass 127.0.0.1:1026; 
}
}
}
}

Редагуємо параметри php:
vi /etc/php.ini

doc_root = "srv/www"
cgi.force_redirect = 1
cgi.redirect_status_env = "так";


І перевіряємо параметри fascgi:
vi /etc/nginx/fastcgi_params

fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx/$nginx_version;
fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;

Додаємо служби в автозавантаження і запускаємо їх:
/etc/init.d/nginx enable
/etc/init.d/nginx start
/etc/init.d/php5-fastcgi enable
/etc/init.d/php5-fastcgi start

Копіюємо файли сайту на сервер у вказану папку і перевіряємо працездатність сайту всередині локальної мережі.
Не забуваємо поміняти http порт нашого роутера і прокинути 80 порт сервера під внешку:
/ip service set port=8080 2 disabled=yes # or no
/ip nat firewall add chain=dstnat action=dst-nat dst-address=внешний_ІР-адреса protocol=tcp dst-port=80 to-ports=80 to-addresses=172.16.0.12 in-interface=ether2 disabled=no # in-interface=WAN порт

На цьому налаштування закінчена.

Висновок

Таким чином, ми отримали умовно (наявність роутера) беслпаный хостинг для персонального сайту з мінімальним енергоспоживанням і споживанням ресурсів роутера.
<habracut/>

Джерело: Хабрахабр

0 коментарів

Тільки зареєстровані та авторизовані користувачі можуть залишати коментарі.